Elevated response times
Incident Report for Peakon
Resolved
This incident has been resolved.
Posted Jul 04, 2022 - 22:42 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 04, 2022 - 19:50 CEST
Investigating
We are currently investigating this issue.
Posted Jul 04, 2022 - 16:29 CEST
This incident affected: Dashboard, Survey, and API.