Cloudflare network issue

Incident Report for Peakon

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 15:53 CET

Monitoring

At the moment we are experiencing errors on Peakon services due to the Cloudflare network issue
https://www.cloudflarestatus.com/incidents/8gmgl950y3h7

Previous incident was closed because CF reported that error rate returned to normal, but the issue is still in place
Posted Nov 18, 2025 - 14:55 CET
This incident affected: Dashboard, Survey, API, 3rd party (Survey CDN, Mobile Push Notifications, Database, Filestorage, Servers, Cloudflare Network, Cloudflare Cloudflare Recursive DNS, Cloudflare Cloudflare Authoritative DNS, Cloudflare DNS Root Servers, Cloudflare DNS Updates, Cloudflare CDN/Cache, Cloudflare Cloudflare Firewall, Cloudflare Data Localization Suite, Cloudflare Rules, Pinecone), and Integrations (Slack Integration, Microsoft Teams Integration).