Elevated response times and error rates

Incident Report for Peakon

Resolved

This incident has been resolved.
Posted Jul 04, 2022 - 13:02 CEST

Investigating

We are currently investigating this issue.
Posted Jul 04, 2022 - 12:37 CEST
This incident affected: Dashboard, Survey, and API.