Delay in sending survey emails
Incident Report for Peakon
Resolved
This incident has been resolved.
Posted May 10, 2021 - 12:11 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 10, 2021 - 10:16 CEST
Investigating
We are currently experiencing delays in sending survey emails. We are working to resolve the issue.
Posted May 10, 2021 - 10:04 CEST